Blog

Far convivere più JVM su Ubuntu 7.10

Ubuntu installa di default una JVM open-source 1.4, che è un pò datata. Per installare le versioni più recenti della Sun bisogna abilitare il repository multiverse quindi selezioniamo:

Sistema>Amministrazione>Sorgenti software

e diamo la spunta su: “Software con restrizioni per copyright o motivi legali (multiverse)”

Dopodichè da terminale:

Questo comando installa il runtime java 1.5 e 1.6 e dovrebbe bastare per gli usi più comuni, se siete sviluppatori e vi serve altro per la lista di tutti i pacchetti relativi a Java (quelli ufficiali della sun) digitate:


Per Installazioni di versioni di java precedenti la 1.5 non ci sono pacchetti ufficiali sun nel multiverse, c’è questo pacchetto

che offre una versione compatible (Blackdown Java2 1.4)…

Ora per scegliere quale versione di Java utilizzare di default da terminale digitate:

e selezionate la JVM che vi serve.

One comment on “Far convivere più JVM su Ubuntu 7.10

Lascia un commento

Scoprite cosa possiamo fare per il vostro business
Tecnologie e Partner